40. Sim Module - Common Tools

Table of Contents

40.1. Drawing flowsheets and adding tables to flowsheets ................................................................. 2
  40.1.1. Drawing units ......................................................................................................................... 2
  40.1.2. Drawing streams ...................................................................................................................... 3
  40.1.3. Renaming and deleting units and streams .............................................................................. 4
  40.1.4. Inserting tables and stream tables (typically done after simulations) ........................................ 4
  40.1.5. Editing a flowsheet .................................................................................................................. 7

40.2. Menus in the flowsheet window ................................................................................................... 9
  40.2.1. Reports ..................................................................................................................................... 14
  40.2.2. Select Unit Models ................................................................................................................... 15
  40.2.3. Scenario Editor ......................................................................................................................... 16
  40.2.4. Scenario Editor – Monte Carlo simulation ............................................................................ 17
  40.2.5. Process Calculation Order ..................................................................................................... 19

40.3. Toolbars ...................................................................................................................................... 23
  40.3.1. Left and Top Toolbars .......................................................................................................... 23
  40.3.2. Docking bars ............................................................................................................................. 27

40.4. Importing HSC Sim 7 models (HSC Sim 6 models are not supported) ........................................ 32

40.5. Fixes for typical Sim problems ..................................................................................................... 33
40.1. Drawing flowsheets and adding tables to flowsheets

This chapter explains how to draw and add tables to a flowsheet. In addition to the instructions chapter, the user should also read unit-specific Chapters 41-47 and 55 of this manual before running the simulations (41-42 Distribution Units, 43-44 Reactions Units, 45-46 Minerals Processing Units, 47 Converter Units, and 55 Dynamic Units, which are needed if different units are combined in the flowsheet).

The most important icons for drawing are:

![Icons for drawing Units and Streams](image)

**Fig. 1.** Icons for drawing Units and Streams, where the first icon is Select, U = Generic Units, R = Reactions Units, D = Distributions Units, t = Dynamic Units and the last icon is Streams

40.1.1. Drawing units

Select the unit by left-clicking the unit icon. The cursor shows the user which icon is active. Move the cursor to somewhere on the flowsheet and draw a unit by a) holding down the left mouse button b) moving the mouse to increase the size of the unit c) releasing the button to stop drawing, see **Fig. 2**. The user can change the size of the units later.

![Drawing two Reactions units](image)

**Fig. 2.** Drawing two Reactions units. The Reactions unit is the active icon in this figure, see the mouse cursor
40.1.2. Drawing streams

Select the stream icon with the mouse (left button). Move the cursor to somewhere on the flowsheet and click the mouse (left button) to start the stream. The user can add a corner to the stream with another click and double-click (left button) to end the drawing of the stream, see Fig. 3.

Editing Streams

How to a) make a corner on the stream b) change the angle of the stream and c) remove the corners of the stream d) change the input and output units of the stream e) check the connection of the streams.

a) Choose the Select icon and by holding down the **shift + left mouse button**, the user can make corners on the streams by moving the mouse.

b) Choose the Select icon and click the stream to see the nodes (blue squares). Hold down the mouse button on a node and move the mouse to change the angle of the stream (hold shift for continuous changing of the angle).

c) Choose the Select icon, select the stream, then select one stream node (blue square), move one node on top of another node to remove a stream corner.

d) Choose the Select icon and move the beginning or end of the stream to a new unit or out of the unit. HSC Sim will suggest a new connection to the stream that the user can accept (OK) or Cancel.

e) When the flowsheet is ready, check that the streams are connected to the correct units. The user can check connections visually, see Fig. 4. A white circle or arrow means that the stream source or destination is unknown (a gray arrow means it is known). Blue stream means input, black stream is between two units and red stream means output. It is also possible to click in the View menu **Toolbars** to show the Process Tree. The most time-consuming task is selecting streams one by one and looking at the properties (process sheet) to see the source and destination of the stream.

---

**Fig. 3. Drawing streams**
40.1.3. Renaming and deleting units and streams

Choose the Select icon and rename units and streams by double-clicking the name label or click the name label and F2 or edit properties (process sheet) - NameID cell, see Fig. 5. Units and streams can also be deleted by choosing them with Selection tool and pressing delete button.

40.1.4. Inserting tables and stream tables (typically done after simulations)

The user can add Tables or Title Tables to visualize important parameters of the results. Choose the Table icon and draw the table in the same way as user draws the units. The user can open table editor by double-clicking the table, where the user can add more rows and columns. It is important to uncheck Size lock when adjusting the table size. It is typical to use this table to show a summary of the results. The user can insert header labels and add any process values as cell references in this table (copy cell reference from the unit sheets and paste cell reference in the table), see Fig. 6 - Fig. 8.
The user can also insert **stream tables** by clicking the Stream Table Editor icon , which will open the editor where the user can add variables by double-clicking them. (Note that the variable list may be empty if you haven’t created a variable list in the reactions unit. Creating a variable list is shown in section 43 Sim Reactions Unit -> 43.2. Creating a Variable List). A visible variable list can be sorted by dragging the variables up and down in the list, see Fig. 9. The user can check which stream tables or flow tables (Fig. 10) can be visible or invisible in the editor or does that later from View Menu...stream tables...show/hide all.

Fig. 6. Table added to the flowsheet.

Fig. 7. Table editor, remember to uncheck **Size lock** when inserting rows and columns.

Fig. 8. Title Table where user can add flowsheet information.
Fig. 9. Stream tables editor for adding stream tables to the flowsheet. Add and remove variables by double-clicking. User can choose different Table Sets for each stream or just one set for all streams.

Fig. 10. In Stream tables the user can now also create Flow Tables to the simulation sheet (by changing Table view Mode in Stream Table Editor).
40.1.5. **Editing a flowsheet**

Sometimes the user wants to edit a flowsheet later and add new units. Adding a new unit (Unit 3) in the middle of a stream (Stream 1) connected to two units (Unit 1 and Unit 2) is explained here. First, draw a new unit (Unit 3) and connect Stream 1 from Unit 1 to Unit 3. Then add a new stream (Stream 2), which starts from Unit 3 and ends at Unit 2, see **Fig. 11** - **Fig. 13**. Information in Unit 1 and Unit 2 is automatically updated so the user only needs to make changes in Unit 3 and Stream 2 to run the simulation.

**Fig. 11.** Adding a unit to a stream between two units: Starting situation.

**Fig. 12.** Adding a unit to a stream between two units: Add new unit (Unit 3) and remove stream connection between units 1 and 2.
Fig. 13. Adding a unit to a stream between two units: Final situation after connecting Stream 1 to Unit 3 and drawing a new stream (Stream 2) from Unit 3 to Unit 2.
40.2. Menus in the flowsheet window

In this section, the Sim flowsheet menus (File, View, Select, Tools, Drawing Tools, Window and Help) are introduced.

**File menu**

This menu is similar to many other programs where the user can (see also Fig. 14):

1. Start **New Process**...which opens an empty flowsheet.
2. **Open Process**...which is a *.Sim or *.fls file (HSC7 flowsheet).
3. **Import Process from Rex**...Import from Rex experimental database (login needed)
4. **Save Process** quick save process (overwrites previous version)
5. **Save Process As**... save process with the file name and location given by the user
6. **Save Process Without Models As**...All models and data will be deleted. Only drawings will be left.
7. **Save as Zip**...save process as zip file. User can give the file name and location
8. **Autosave**... enable the autosave feature. The file will be auto-saved periodically (15, 30 or 60 minutes) without overwriting (each auto-saved file is stored separately).
9. **Save Backup** process should be saved first before a backup can be made. It is recommended to save a backup from time to time during the simulation.
10. **Backup Manager**... If the user has saved backups, they can be managed (checked, restored, deleted) here.
11. **Flowsheet Settings**... change or restore default settings of the flowsheet, see Fig. 15.
12. **Recent Processes**... shows the 10 most recent simulations made by the user
13. **Export Flowsheet Image**... The user can export the flowsheet as an image (doc, png, vdx, pdf, svg or dxf) or copy a flowsheet picture to the clipboard to use it in reports and presentations.
14. **Print Flowsheet** prints the flowsheet
15. **Exit HSC Sim** will close the Sim program
Fig. 15. Flowsheet settings.

View menu

Fig. 16. View menu.
In the View menu the user can:

1. **Show or hide Diagram items using** **Object Visibility**.

![Object Visibility window](image1.png)

*Fig. 17. Object visibility window.*

2. **Give alias names to units and streams using** **Rename Alias**.

![Rename Alias window](image2.png)

*Fig. 18. Rename Alias window.*

3. **Check and uncheck all** **Toolbars**, which are explained in section 40.3.
Select menu

The Select menu is typically used to edit or move many properties at once. Here the user can: (see Fig. 19 below)

1. Select all Units on the flowsheet.
2. Select all Unit Name Labels on the flowsheet.
3. Select all Streams on the flowsheet.
4. Select all Stream Name Labels on the flowsheet.
5. Select all Stream Value Labels on the flowsheet.
6. Select all Stream Tables on the flowsheet.
7. Select Header Label on the flowsheet.
8. Select all Name Labels on the flowsheet.
9. Select all Value Labels on the flowsheet.
10. Select all Text Labels on the flowsheet.
11. Select All Labels on the flowsheet.
12. Select Multi-line Text Boxes on the flowsheet.
13. Select all General Tables on the flowsheet.
14. Select all Value Cells on the flowsheet.
15. Select all Title Tables on the flowsheet.
16. Select All Tables (not including stream tables) on the flowsheet.
17. Select Polylines on the flowsheet.
18. Select Picture Boxes on the flowsheet.
19. Select all Other Drawing Objects on the flowsheet.
20. Select All Items on the flowsheet.

Fig. 19. Select menu.
Tools menu

The Tools menu includes many advanced options that may be needed in flowsheet simulation. New user needs detailed instructions on how to use those tools. Some tools are explained here and others in different Chapters, see the list below.

The Tools menu includes:

1. **Process Information**
   
   ![Fig. 21. The user can add Process Information to this sheet.](image)

2. LCA Evaluation (see Chapter 49)
3. Mass Balance (see Chapters 51 and 52)
4. Model Fit (see Chapter 53)
5. Reports (see section 40.2.1)
6. Select Unit Models (see section 40.2.2)
7. Scenario Editor (see section 40.2.3)
8. Process Calculation Order (see section 40.2.4)
9. Neural Networks (see Chapter 95)
10. Thermoeconomics Calculator (see Chapter 54)
11. Model Species (see Chapter 28)
40.2.1. Reports

A summary of flowsheet results can be saved and printed here. There are two pages in this report sheet: one for units and one for streams. This report uses Hydro_example.Sim.

---

**Fig. 22.** Stream balance sheet of the report file.

**Fig. 23.** Unit balance sheet of the report file.

**Fig. 24.** Properties sheet of the report file.
40.2.2. **Select Unit Models**

The user can choose different models for the units. The Select Unit Models window (see Fig. 25) can be opened from the Tools menu or by right-clicking if the cursor is on top of one of the units and choosing Select Unit Models option. On the left side of the window is the list of the units on the flowsheet. In the middle part the user can select a unit model from the Reactions, Distributions, Particles, Others and Import (users own unit models) sheet. **Double-click** the unit to select it and then click OK. Most of the units are DLL type but there are still some Excel Wizards available for the Reactions units. If Excel Wizards are chosen, the user needs to check the stream names. Information about the units can be found on the right side of the selector window. Empty Reactions or Distributions units are the same as R and D unit Icons on the main flowsheet DrawBar, see Fig. 1. Instructions on how users can make their own DLL units is available in Chapter 50.

If user has many units with similar settings: draw flowsheet with all units, edit one unit, save flowsheet and import this unit information to other units using import Unit button (browse *.xlsx file and click Open, Select Imported sheet and units, double-click imported excel unit and click ok), see Fig. 26.

![Fig. 25. Select Unit Models window.](image)

![Fig. 26. Imported units. Are shown after Import Unit... icon is used.](image)
40.2.3. **Scenario Editor**

The Scenario Editor lets user run user’s process model with different operating parameters and see how they affect process variables. The calculated results can then be collected in the charts.

To use the Scenario Editor, first select the processing parameter that is wanted to be regulated and copy its cell reference from the appropriate cell. Next, open the Scenario Editor and paste the cell reference in the first SET/GET column (Fig. 27). Then add a name and measurement unit for this variable, but most importantly specify whether the variable will be a regulated (SET) or a calculated variable (GET) (Fig. 28).

![Fig. 27. Add variables to the Scenario Editor by pasting the cell reference of the variable cell.](image1)

![Fig. 28. Specify the SET/GET value for the variable.](image2)

After adding enough variables, specify the parameter values for the SET columns, add some charts, and finally run the scenario (Fig. 29).
40.2.4. Scenario Editor – Monte Carlo simulation

The scenario editor allows the user to simulate the process with randomly selected input parameters. This can be sometimes a useful method for finding optimum process parameter windows for complex models.

To activate the random sampling of a SET variable, check the Monte Carlo configuration rows visible and set the Monte Carlo value ON for the SET columns to be sampled with randomly selected values (Fig. 30).

Fig. 29. Results of the scenario.

Fig. 30. Setting SET columns as randomly sampled variables.
The randomly sampled SET variables can be specified with a probability distribution (Uniform, Normal, Laplace or Trapezoid) and with parameters which adjust the distribution. To visualize the distribution, check the Distribution Charts option and move between the SET columns (Fig. 31).

Once the variables and distributions are specified, run the scenario and plot the results in charts (Fig. 32).
40.2.5. Process Calculation Order

With this option the user can see the flowsheet information and connections of the process streams with colors. If a stream is not connected to the unit, it will not be visible in this process tree.

![Process Calculation Order](image)

**Fig. 33.** Process calculation order.
Drawing Tools menu

The user can edit the flowsheet using Drawing Tools by aligning, sizing, rotating, grouping, and drawing, see Fig. 34.

One handy way of editing the flowsheet is Edit Pages and Layers where user can set layers and properties which are visible or invisible on the flowsheet, see Fig. 35. Each page can have many layers. Different flowsheet items can be put to different layers in Properties (Location) windows see Fig. 61 and Fig. 62. Then user can be show or hidden different items using Layers check boxes.

The user can find more details about Drawing Tools in section 40.3.

Fig. 34. Drawing tools.

Fig. 35. Edit Pages and Layers window.
Window and Help menus

The Window menu shows the user the name of the flowsheet, see Fig. 36.

The Help menu shows a link to Tutorial Videos, a link to the Sim manual, update checking for the latest version of HSC, and a list of software developers and technical advisors, see Fig. 37 and Fig. 39.

Fig. 36. Window menu.

Fig. 37. Help menu.

Fig. 38. Check for Updates menu.
Fig. 39. About HSC Sim.
40.3. Toolbars

In the View Toolbars menu, the user can check and uncheck toolbars. It is also possible to **Reset Docking Bar Positions** back to their default places. Toolbars are divided into three lists: Docking bars, Left Toolbars, and Top Toolbars, see Fig. 40.

![Fig. 40. List of toolbars.](image)

40.3.1. Left and Top Toolbars

The Left and Top Toolbars are listed and guidance on their usage briefly described in Fig. 41 - Fig. 56. Many drawing options can be later edited from docking toolbar *Properties* after they have been drawn (section 40.3.2).

![Fig. 41. Units and Streams. Select or Draw Units or Draw Streams (see also section 40.1).](image)

![Fig. 42. Calculations. Simulate, Clear Internal Streams, Ignore Warnings, Enable/Disable Calculation Log and give the number of iteration Rounds for calculations.](image)
Fig. 43. Stream 3 is an internal stream. User can empty this stream by clicking **Clear Internal Streams** button; see Fig. 42.

Fig. 44. Visualization. Select or unselect visualization mode and select the stream property that is visualized. The user can also change measurement units, open the Stream Table Editor, visualize stream connections, add a header and copy the flowsheet image to the clipboard using this toolbar.

Fig. 45. Drawing tool. With this toolbar the user can draw line, add shapes like an ellipse, a rectangle and a rounded rectangle. It is also possible to add a text label, a text box and a picture.

Fig. 46. Height and Width. With this toolbar the user can make the size or spacing of the selected units or streams equal. At least 3 units are needed to equal spacing of the units.

Fig. 47. Align. With this toolbar the user can align selected units in many ways, thus making it easier to draw professional-looking flowsheets.

Fig. 48. Layers. With this toolbar the user can change the position of overlapping units or edit pages and layers (Fig. 35).

Fig. 49. Rotate and Flip. With this toolbar the user can rotate or flip units.

Fig. 50. Lock and Unlock. With this toolbar user can disable or enable edit mode for flowsheet drawing and lock or unlock any editing of the entire process, but with drawing lock you can still edit unit properties by opening the unit. Note! Both lock options unable drawing of the flowsheet, see Fig. 56.
Fig. 51. Text Formatting. With this toolbar you can easily edit text labels.

Fig. 52. With the status bar the user can fit and zoom the flowsheet and check and uncheck the Orthogonal, Persist Tool, Autosave and Snap to Grid options. If user wants to draw Orthogonal streams or lines (see Fig. 41 and Fig. 45) check this option. The Persist Tool remembers the last used drawing tool so that the user does not have to select the same tool again separately. The Snap to Grid option aligns the streams and units according to the grid on the flowsheet, thus making it easier to draw professional-looking flowsheets. User also sees size of the chosen object and position of the mouse cursor.

Fig. 53. The user can start a new or open an old process. It is also possible to save the process or save a backup or zip file (archive) of the process, using this toolbar.

Fig. 54. The user can insert a Table or Title Table using this toolbar (see also section 40.1.4).

Fig. 55. Dynamic. With this toolbar the user can open the dynamic dialogue, run/pause/stop the dynamic simulation, follow the simulation time, as well as empty the tanks in every unit (see also Chapter 55).
Fig. 56. Locking of the flowsheet (Fig. 50) changes drawing toolbars gray and highlights the flowsheet frame green (or red if user locks entire process).
40.3.2. Docking bars

**Fig. 57.** Log viewer. This docking bar shows the user possible warnings and errors found during the simulation.

**Fig. 58.** Cell References. This docking bar shows the user possible Cell References and their location in the flowsheet.

**Fig. 59.** Process Tree. In this docking bar the user sees the flowsheet as a process tree.
Fig. 60. Unit Controls. In this docking bar, the user can check and modify the unit controls in the simulation.

Fig. 61. Properties - Unit Drawings and Process.

Fig. 62. Properties - Stream Drawings and Process
Fig. 63. View…Toolbars…Process Errors.

Fig. 64. Unit Icons (Unit List Panel). With this docking bar the user can add Unit pictures to the flowsheet. The unit pictures are of generic type (see section 40.2.2). The user can switch the view, browse picture location, search by name, or change unit directory (top bar) or zoom icons (bottom bar).

Fig. 65. View…Toolbars…Info and Links. The user can add for example instructions on how to use the flowsheet here.
Fig. 66. Stream Content Viewer. In this docking bar the user can see a tabulated summary of the stream properties.

Fig. 67. Stream Visualization Settings. In this docking bar the user can change the settings of the Sankey diagram (thickness of the stream shows where most of the material goes).
Fig. 68. Right mouse-click and choose Run control.

Fig. 69. View…Toolbars…Control monitor. Click Draw Function to visualize how run control is reached.
40.4. Importing HSC Sim 7 models (HSC Sim 6 models are not supported)

In HSC Sim there is a built-in support for importing HSC Sim 7 models and then using them in Sim. However, there are some points and limitations that the user should take into consideration when importing Sim 7 models into Sim. If points listed here do not help please contact the developers.

Major points:

- Sim calculations have dramatically stricter error checks than Sim 7. When the user imports an old model and tries to run it, often the calculation will notify of an error in the flowsheet. The user can locate the errors using the log viewer and then fix them manually.
- There are some changes in the Sim hydro variable list logic when compared to Sim 7. If the imported model variable list contains species not found in the database, the user needs to go through them case by case in the Sim variable list editor. The user can add entries to the database, use a different database entry, or delete the species from the variable list to fix this (see Chapter 43, section 43.2.1).
- Sim 7 solvent extraction hydro Excel Wizards are no longer supported in Sim. If the imported model contains them in Sim, the user will not be able to run the model successfully.
- There is a completely new DLL unit operation system in Sim, which has been implemented for some Mineral Process unit operation models. Sim has partial support for using old Sim 7 minpro Excel Wizard models and the user should be able to run calculations for the imported Sim 7 minpro Excel Wizards. However, the user cannot currently edit or make the Excel Wizards for the old minpro models. If users want to edit their old mineral process models, they should replace the old minpro Excel Wizards with the new DLL models.

Minor points:

- Sim uses different Stream Tables than Sim 7. Because of this, users cannot edit Sim 7 Stream Tables in Sim but they can make new ones using Sim tools.
- The visibility of the connected streams is forced on for input and output streams in Sim. If there are any such streams hidden in the imported Sim 7 model, they will appear in Sim.
- A few drawing objects like a Bézier curve are not supported in the first version of Sim.
- In some rare cases, Sim does not recognize Sim 7 stream connections correctly. Information about this will be given in the import log. Afterwards the user should manually confirm the notified stream connections.
- In Sim 7, the user had the possibility to encrypt some units. This function is no longer supported in Sim, which means those units will not be loaded during the import.
- External workbook references work differently in Sim 7 and Sim. When user imports a Sim 7 model, all external references are changed and will include “REF” at the beginning of the reference.
- Sim 7 used automatically safe division for all division operations in the workbook. This meant that, for example, 0/0 did not give an error as the answer. Sim adds the “safediv” function to division operations.
- Sim will change the sheet names of the workbook if the sheet contains illegal characters like “/”.

Outotec reserves the right to modify these specifications at any time without prior notice. Copyright © Outotec 2019
40.5. Fixes for typical Sim problems

Make it easier to read what’s on your screen

You can change the size of text and other items on your screen by choosing one of these options. To temporarily enlarge just part of the screen, use the Magnifier tool.

- Smaller - 100% (default)
- Medium - 125%
- Larger - 150%

Fig. 70. If you use text and other items size that is larger than 100 % you may have problems of drawing flowsheets in Sim.

Fig. 71. Solution to window resize problem in Sim. You need to check “Disable display scaling on high DPI settings from Sim properties.”